Codebase list empathy / debian/2.30.0.1-1 debian / rules
debian/2.30.0.1-1

Tree @debian/2.30.0.1-1 (Download .tar.gz)

rules @debian/2.30.0.1-1raw · history · blame

#!/usr/bin/make -f

DEB_DH_INSTALL_SOURCEDIR=debian/tmp

include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/gnome.mk

# List any files which are not installed
include /usr/share/cdbs/1/rules/utils.mk
common-binary-post-install-arch:: list-missing

# Ensure at build time that the library has no dependencies on undefined
# symbols, and speed up loading.
#LDFLAGS += -Wl,-z,defs -Wl,-O1

DEB_CONFIGURE_EXTRA_FLAGS := --enable-spell \
                             --disable-tests \
                             --enable-webkit \
                             --enable-map \
                             --enable-nautilus-sendto

DEB_DBG_PACKAGE_empathy = empathy-dbg

DEB_BUILD_ARCH_OS := $(shell dpkg-architecture -qDEB_BUILD_ARCH_OS)

ifeq ($(DEB_BUILD_ARCH_OS),linux)
  DEB_CONFIGURE_EXTRA_FLAGS += --with-connectivity=nm --enable-location=yes
else
  DEB_CONFIGURE_EXTRA_FLAGS += --with-connectivity=no --enable-location=no
endif

include $(CURDIR)/debian/update-patches.mk