Codebase list empathy / debian/3.4.1-1 debian / rules
debian/3.4.1-1

Tree @debian/3.4.1-1 (Download .tar.gz)

rules @debian/3.4.1-1raw · history · blame

#!/usr/bin/make -f

include /usr/share/cdbs/1/rules/autoreconf.mk
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/gnome.mk

# List any files which are not installed
include /usr/share/cdbs/1/rules/utils.mk
common-binary-post-install-arch:: list-missing

# Ensure at build time that the library has no dependencies on undefined
# symbols, and speed up loading.
LDFLAGS += -Wl,-z,defs -Wl,-O1 -Wl,--as-needed

DEB_CONFIGURE_EXTRA_FLAGS := --enable-spell=yes \
                             --enable-webkit=yes \
                             --enable-location=yes \
                             --enable-geocode=yes \
                             --with-cheese \
                             --with-eds \
                             --enable-call-logs=yes \
                             --enable-call=yes \
                             --enable-nautilus-sendto=yes \
                             --enable-empathy-av \
                             --disable-schemas-compile \
                             --enable-map=yes \
                             --enable-goa=yes

DEB_BUILD_ARCH_OS := $(shell dpkg-architecture -qDEB_BUILD_ARCH_OS)

ifeq ($(DEB_BUILD_ARCH_OS),linux)
  DEB_CONFIGURE_EXTRA_FLAGS += --with-connectivity=nm --enable-gudev=yes
else
  DEB_CONFIGURE_EXTRA_FLAGS += --with-connectivity=no --enable-gudev=no
endif

DEB_DH_MAKESHLIBS_ARGS_empathy = --no-act

include $(CURDIR)/debian/update-patches.mk