Codebase list python-pygerrit2 / 2244cfb3-896f-4cd4-9890-2cd1dd89ae80/main debian / rules
2244cfb3-896f-4cd4-9890-2cd1dd89ae80/main

Tree @2244cfb3-896f-4cd4-9890-2cd1dd89ae80/main (Download .tar.gz)

rules @2244cfb3-896f-4cd4-9890-2cd1dd89ae80/mainraw · history · blame

#!/usr/bin/make -f
include /usr/share/dpkg/pkg-info.mk

# Parse version from debian changelog (or pbr will try to use Git commit)
export PBR_VERSION=$(DEB_VERSION_UPSTREAM)
export PYBUILD_NAME=pygerrit2

%:
	dh $@ --with python3 --buildsystem=pybuild

override_dh_auto_test:
	PYBUILD_SYSTEM=custom \
		PYBUILD_TEST_ARGS="{interpreter} unittests.py" \
		dh_auto_test