Codebase list python-pygerrit2 / debian/2.0.4-1 debian / rules
debian/2.0.4-1

Tree @debian/2.0.4-1 (Download .tar.gz)

rules @debian/2.0.4-1raw · history · blame

#!/usr/bin/make -f
include /usr/share/dpkg/pkg-info.mk

# Parse version from debian changelog (or pbr will try to use Git commit)
export PBR_VERSION=$(DEB_VERSION_UPSTREAM)
export PYBUILD_NAME=pygerrit2

%:
	dh $@ --with python2,python3 --buildsystem=pybuild

override_dh_auto_test:
	PYBUILD_SYSTEM=custom \
		PYBUILD_TEST_ARGS="{interpreter} unittests.py" \
		dh_auto_test