Codebase list findbugs / 5c072dba-ab4e-484d-8280-d43e04746755/main debian / patches / 0016-dom4j2-compatibility.patch
5c072dba-ab4e-484d-8280-d43e04746755/main

Tree @5c072dba-ab4e-484d-8280-d43e04746755/main (Download .tar.gz)

0016-dom4j2-compatibility.patch @5c072dba-ab4e-484d-8280-d43e04746755/mainraw · history · blame

Description: Fixes the compatibility with dom4j 2.x
Author: Emmanuel Bourg <ebourg@apache.org>
Forwarded: no
--- a/src/java/edu/umd/cs/findbugs/xml/XMLUtil.java
+++ b/src/java/edu/umd/cs/findbugs/xml/XMLUtil.java
@@ -30,7 +30,7 @@
 
     @SuppressWarnings("unchecked")
     public static <T> List<T> selectNodes(Node node, String arg0) {
-        return node.selectNodes(arg0);
+        return (List) node.selectNodes(arg0);
     }
 
 }